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10 Applying References
and Hyperlinks

KEY TERMS
 • bookmark

 • endnote

 • footnote

 • hyperlink

 • tab leader

 • table of contents

LESSON SKILL MATRIX

Skill Exam Objective Objective Number

Applying a Hyperlink Apply a hyperlink to text or graphic. 6.1.1
 Use a hyperlink as a bookmark. 6.1.2
 Link a hyperlink to an email address. 6.1.3

Creating Endnotes and Footnotes Demonstrate the difference between 6.2.1
 in a Document  endnotes and footnotes.  
 Confi gure footnote and endnote format. 6.2.3
 Manage footnote and endnote locations. 6.2.2
 Change footnote and endnote numbering. 6.2.5
 Presentation. 6.2.4

Creating a Table of Contents Use default formats. 6.3.1
 in a Document Set tab leaders. 6.3.4
 Set alignment. 6.3.3
 Set levels. 6.3.2
 Modify styles. 6.3.5
 Update a table of contents. 6.3.6
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 Applying References and Hyperlinks 255

You have just begun a new career as a project manager at Proseware, Inc., a web 

development company. One of the responsibilities of this position includes meet-

ing with new clients who want to develop new websites or redesign existing sites. 

To help make this process easier, you decide to create a template that you can use 

to plan website development for each client. Although the template is only about 

seven pages long, you know it will get longer as the sections are fi lled in and com-

pleted for each client. In this lesson, you will apply a hyperlink to text and graphics, 

apply bookmarks in a document, link to an email address, create endnotes and 

footnotes, and create a table of contents so that all sections of the document can 

be referred to easily among client representatives and coworkers during the plan-

ning and development of websites.

UNDERSTANDING HYPERLINKS
A hyperlink is a location to an internal or external page that readers follow when opening a 
new page. To access the page, you would press the left mouse button on the hyperlink. Hyper-
links can be applied to text or graphics and these can be in the document where the link would 
jump from one page to the next. Hyperlinks can be external links to a web page on the Internet. 
The hyperlink follows a specifi c target location within the document as a bookmark, as an email 
address, or to an external location. Hyperlinks can be applied to text or graphics. In this exercise, 
you learn to apply a hyperlink to text and an image, remove a hyperlink and ScreenTip, add a 
bookmark, and add an email as a hyperlink.

Applying a Hyperlink
Working with hyperlinks quickly takes you to the location within the document, web page, 
bookmark, or email address. In this exercise, you learn to insert a hyperlink in text and an image, 
add a ScreenTip, and remove a hyperlink and ScreenTip.

STEP BY STEP Apply a Hyperlink

GET READY. Before you begin these steps, be sure to launch Microsoft Word.

 1. OPEN the proseware_weblayout document from the lesson folder.

 2. On the Home tab, in the Paragraph group, click the Show/Hide button to enable.

 3. Select the company name, Proseware, Inc.

 4. On the Insert tab, in the Links group, click the Hyperlink button to open the Insert 
Hyperlink dialog box as shown in Figure 10-1. The Insert Hyperlink dialog box opens.

The Bottom Line

WileyPLUS Extra! features an 
online tutorial of this task.

Figure 10-1

Insert Hyperlink dialog box

Default settings, Existing 
File or Web Page

Place in This Document

Create New Document

To insert an 
E-mail Address

Automatically displays 
highlighted text 

Up one folder

ScreenTip. 

Browse for file

Web address location.  Begin with 
http://www.proseware.com. 

Browse the web

Create a bookmark 
within the document.

          The proseware_
weblayout document fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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 256 Lesson 10

 5. In the Address box, key http://www.proseware.com/. Click OK. You have created a link 
for the company to link directly to the external website.

 6. In text, the company name appears underlined in blue and is linked. Since this is a 
fi ctitious company, the link will direct you to the Microsoft offi cial website. To check 
the link, press the Ctrl key and click to go directly to the website. Notice the ScreenTip 
appearing above the hyperlink. When you click on the link, the hyperlink changes to 
another color. Also, when you hover over the link, you will see the ScreenTip.

 7. Select the fi rst image to the top left. The next step is to link the graphic to the company 
website.

 8. In the Links group, click the Hyperlink button. With the dialog box open, key http://
www.proseware.com. As you begin keying, Autofi ll recognizes text and completes the 
entry for you.

 9. Click the Screen Tip button. The Set Hyperlink Screen Tip dialog box appears. Key PWI. 
Click OK to close the Set Hyperlink Screen Tip dialog box. Click OK to close the Edit 
Hyperlink dialog box.

 10. Place your insertion point over the fi rst image and notice the ScreenTip PWI appears.

 11. Repeat steps 6–8 for the second image and test your links.

 12. SAVE the document as proseware_weblayout_links in your USB fl ash drive in the 
lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Removing a Hyperlink and ScreenTip
Once a hyperlink is removed, it will no longer be linked to a document or external web location. 
Hyperlinks are removed the same way for text and images. After a ScreenTip is deleted, it will 
not display in the hyperlink. In this exercise, you learn to remove a hyperlink and ScreenTip.

 STEP BY STEP Remove a Hyperlink and ScreenTip

USE the document open from the previous exercise.

 1. Select the second image.

 2. Use the shortcut keyboard command Ctrl+K to access the Insert Hyperlink dialog box.

 3. Click Remove Link to remove the hyperlink.

 4. Select the fi rst image and on the Links group, click the Hyperlink button.

 5. Click the Screen Tip button and delete PWI. Click OK.

 6. Place your insertion point over the fi rst image and notice the ScreenTip no longer 
appears.

 7. SAVE the document as proseware_weblayout_links1 in your USB fl ash drive in the 
lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Adding a Bookmark
A bookmark is a location or a selection of text that you name and identify for future reference. 
For instance, you may like to revisit a page in a document and locate text; in this case, you could use 
the Bookmark dialog box and get there quickly using the name of the bookmark you created. Book-
mark names can contain numbers, but they must begin with a letter. You cannot have any spaces in 
a bookmark name, so use an underscore to separate words or put the words together—for example, 
Trade_Secrets or TradeSecrets. In this exercise, you learn to add a bookmark inside a document.

6.1.1

How do you apply a 
hyperlink to text?

6.1.1

How do you apply a 
hyperlink to a graphic?

 Another Way
Using the shortcut 

Ctrl+K will open the Insert 
Hyperlink dialog box.
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 Applying References and Hyperlinks 257

STEP BY STEP Add Bookmark

USE the document open from the previous exercise.

 1. Select the Web Site Creation Strategy text.

 2. On the Insert tab in the Links group, click the Hyperlink button. In the Insert Hyperlink 
dialog box, click the Bookmark button. The Select Place in Document dialog box 
opens.

 3. Scroll up and select Top of the Document as shown in Figure 10-2. Click OK to 
close the Select Place in Document dialog box. Notice the Address bar in the Insert 
Hyperlink dialog box displays in the box #Top of the Document—this will link to the 
beginning of the document. Click OK to close the Insert Hyperlink dialog box.

Figure 10-2

Select Place in Document
dialog box

Bookmark is set to link 
to top of document.

 4. Press Ctrl+End to move to the end of the document.

 5. Press Enter after the email image and key Back to Top.

 6. Select Back to Top then press Ctrl+K to open the Insert Hyperlink dialog box.

 7. Click the Bookmark button and scroll up and select Top of the Document. Click OK 
twice. The Back to Top link changes to a Bookmark link.

 8. Test the Bookmark by pressing and holding the Ctrl key and clicking the Back to Top 
link. Notice that it automatically goes to the top of the document.

 9. SAVE the document as proseware_weblayout_links2 in your USB fl ash drive in the 
lesson folder.

 10. The next step is to create bookmarks based on headings and use the Go To command 
to go directly to the bookmark.

 11. On page 2, double-click to select the word Strategy. In the Links group, click the 
Bookmark button and key the word Strategy in the box. Click Add and the word 
Strategy is added, as shown in Figure 10-3. Complete step 11 again for the headings 
listed in the table below until the additional fi ve text items are bookmarked. In the last 
item after clicking Add, click OK to close the Bookmark dialog box.

Plan

Discovery

Design

Implementation

Stabilization
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 258 Lesson 10

 12. Bookmark names can contain up to 40 characters and spaces are not allowed when 
using Bookmarks; therefore, you would use an underscore to separate words. With 
Stabilization still highlighted, click Bookmark again. Your screen should match 
Figure 10-4. Click Cancel.

To add a bookmark, key text 
in box, then click Add.

To delete a bookmark, select 
bookmark, then click Delete.

Find  the bookmarked location 
in the text by selecting the  
bookmark, then clicking Go 

Figure 10-3

Bookmark dialog box

Figure 10-4

Bookmark dialog box with
bookmarks added

 13. Position the insertion point at the beginning of the document by pressing Ctrl+Home. 
In the Links group click the Bookmark button. Test each link by selecting the bookmark 
name and then click the Go To button. Select Design and then click Go To, and the word 
is automatically highlighted in the document. After testing all bookmarks, click Close.

 14. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

You can access the Go To command in one of the following ways: (1) use the Select Browse 
Object, (2) click the shortcut key F5, or (3) click the Edit group, and then click the Find 
Button. Using any one of these commands will open the Find and Replace dialog box, as you 
learned in Lesson 2.

6.1.2

How do you insert a 
bookmark in a document?

            
Ref

Troubleshooting If your bookmark does not run properly, delete the bookmark, select the text, key the same 
text, and then click Add.
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 Applying References and Hyperlinks 259

Adding an Email as a Hyperlink
An email address link is used to provide contact information, elicit feedback, or request informa-
tion. In this exercise, you learn to add an email as a hyperlink.

STEP BY STEP Add an Email as a Hyperlink

USE the document open from the previous exercise.

 1. Press Ctrl+End to move to the end of the document.

 2. Click the email image to select it.

Email links can be applied to text or images.
 3. In the Links group of the Insert tab, click the Hyperlink button or press Ctrl+K. The 

Insert Hyperlink dialog box opens.

 4. Under the Link to section, click E-mail Address. Notice the middle portion of the dialog 
box changes. In the E-mail address section, key manager@proseware.com in the 
box. Mail to automatically appears when you begin keying the email address. For the 
Subject box, key Web Design as displayed in Figure 10-5. Click the ScreenTip button 
to open the Set Hyperlink Screen Tip dialog box; then in the ScreenTip text box, key 
Manager. Click OK twice.

Take Note

Figure 10-5

Insert Hyperlink dialog box
E-mail Address link

To create a ScreenTipKey email address. 
Mailto: automatically 
displays.

Key a subject 
in the box.

Select E-mail Address 
to insert link.

Select image or text to 
create an e-mail link.

 5. Hover your mouse over the E-mail image and the Screen Tip Manager appears. Test 
your email link by pressing the Ctrl key and clicking the left mouse button once. 
Outlook automatically opens with the email address and subject line inserted. This 
type of hyperlink is known as a mailto link.

 6. SAVE the document in your USB fl ash drive in the lesson folder and close the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

CREATING FOOTNOTES AND ENDNOTES
Both endnotes and footnotes are citations in a document. A footnote is placed at the bottom 
of the page in the document on which the citation is located, while an endnote is at the end 
of document. Footnotes and endnotes are automatically numbered. Edits to a footnote or end-
note are made within the text. Deleting a footnote or endnote will automatically renumber the 
remaining footnotes or endnotes. As a student, you will use these in your research papers. In this 
lesson, you learn to insert a footnote and endnote into a document.

6.1.3

How do you apply a hyperlink 
to an email address?

The Bottom Line
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 260 Lesson 10

Creating Footnotes in a Document

STEP BY STEP Create Footnotes and Endnotes

GET READY. Before you begin these steps, be sure to launch Microsoft Word.

 1. OPEN the fi rstladies document from the lesson folder.

 2. Place the insertion point at the end of the third paragraph.

 3. On the References tab, click the Insert Footnote button in the Footnotes group, as 
shown in Figure 10-6. A superscript 1 is placed after the paragraph and at the end of 
the document.

WileyPLUS Extra! features an 
online tutorial of this task.

Figure 10-6

References tab
Insert Endnote

Insert Footnote button Launch the Footnote and 
Endnote dialog box

Navigate to footnote 
or endnote

Show Notes

 4. Key Mayo, Edith and Denise, Meringolo. First Ladies: Political Role and Public Image. 
Washington: Smithsonian Institute, 1994. At the end of the third paragraph is a 
superscript 1, place the insertion point by the superscript and a ScreenTip appears 
displaying the footnote text.

 5. On page 1, fourth paragraph, place the insertion point at the end of the second 
sentence (before Anthony). In the Footnotes group, click the Insert Footnote button. A 
superscript 2 is placed after the punctuation.

 6. At the bottom of the document page, key Anthony, Carl Sferrazza. American’s First 
Families: An Inside View of 200 Years of Private Life in the White House. New York: 
Simon & Schuster, Inc., 2000. The bottom of page 1 should resemble Figure 10-7.

Figure 10-7

Unformatted footnotes

Unformatted footnote at 
bottom of page. A border 
line automatically 
appears above footnote.

Second 
footnote 
added

 7.  On page 2, fi fth paragraph, end of third sentence, in the Footnotes group, click the 
Insert Footnote button. A superscript 3 is placed after the punctuation.

 8.  At the bottom of the document page, key Gutin, Mayra G. The President’s Partner: The 
First Lady in the Twentieth Century. Westport: Greenwood Press, 1989.

 9.  SAVE the document as fi rstladies_footnotes in your USB fl ash drive in the lesson 
folder.

PAUSE. LEAVE the document open to use in the next exercise.

6.2.1

How do you create 
a footnote?

          The fi rstladies 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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 Applying References and Hyperlinks 261

Formatting Footnotes and Endnotes
According to the Modern Language Association (MLA), a bottom-of-the-page footnote in MLA 
Style is single spaced with a hanging indent and double spacing between each footnote, whereas 
an endnote is double-spaced with no hanging indent. The dialog box contains additional op-
tions to change the numbering format and location for both footnotes and endnotes. In this 
lesson, you learn to format a footnote and endnote.

STEP BY STEP Format Footnotes

USE the document open from the previous exercise.

 1. Press and hold the left mouse button to select the fi rst footnote beginning with Mayo. . . 
1994.

 2. On the Home tab, in the Paragraph group, launch the Paragraph dialog box and 
change the indent to a hanging indent and spacing after to 12. Click OK.

 3. Press and hold the left mouse button to select the second footnote and repeat step 2 
to create a hanging indent.

 4. For footnote number 3, repeat steps 1 to select and 2 to create a hanging indent. The 
footnotes have been formatted with a hanging indent and spaced appropriately.

 5. Place your insertion point after the superscript 1 at the bottom of the document on 
page 1. On the References tab in the Footnotes group, click the arrow to launch the 
Footnote and Endnote dialog box. The Footnote and Endnote dialog box opens. 
In the Format section by Number format, click the drop-down arrow and select 
the uppercase Roman numerals, as shown in Figure 10-8. Click Apply. Notice the 
numbering format has changed.

Click drop-down arrow 
to change number 
format for footnote.

Figure 10-8

Footnote and Endnote
dialog box

 6. In the third paragraph, place your insertion point before the fi rst footnote superscript 
on page 1, press and hold the left mouse button to select the footnote. Launch the 
Footnote and Endnote dialog box. The Footnote and Endnote dialog box opens. In 
the Location section, by Footnotes, click the drop-down arrow and select Below text. 
Click Apply. The fi rst footnote is moved below the third paragraph with a continuous 
section break.

 7. Repeat the same steps for the second and third footnote to place them below text.

 8. SAVE the document as fi rstladies_footnotes1 in your USB fl ash drive in the lesson 
folder.

 9. Place the insertion point behind the second footnote on the fourth paragraph, at the 
end of the second sentence. Delete the footnote. Notice the footnote number 3 is now 
2. Footnotes are automatically renumbered and rearranged when one is deleted. Click 
Undo .

 10. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

6.2.3

How you do organize 
endnotes and footnotes?

6.2.2

How do you change the 
position location for a 
footnote or endnote?

6.2.5

How do you change footnote 
and endnote numbering 

format?

6.2.4

How you do change the 
presentation of footnotes on 

the page?
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 262 Lesson 10

Converting Footnotes and Endnotes
It is easy to convert from a footnote to an endnote. The process is the same for both types of notes. 
In this exercise, you learn to convert from footnotes to endnotes and to format the endnote.

OPEN the fi rstladies_footnotes document completed earlier in this lesson.

 1. The insertion point is at the beginning of the fi rst footnote below the horizontal line.

 2. On the References tab in the Footnotes group, click the arrow to launch the Footnote 
and Endnote dialog box. The Footnote and Endnote dialog box opens.

 3. Click the Convert button. The Convert Notes dialog box opens. The fi rst option Convert 
all footnotes to endnotes is selected, as shown in Figure 10-9. Click OK to convert the 
notes and close the Convert Notes dialog box.

Figure 10-9

Convert Notes
dialog box

Opens the Convert 
Notes dialog box

 4. Click Insert to close the Footnote and Endnotes dialog box. Scroll through to the end 
of the document and notice the footnotes are no longer positioned at the end of the 
page. The endnotes display at the end of the document in lowercase Roman numerals.

 5. Place the insertion point after the last paragraph in the document and insert a page 
break.

 6. Select the endnotes from beginning to end and format them by double spacing and 
create a hanging indent. The document should display as Figure 10-10.

Figure 10-10

Formatted endnote

Endnotes appear 
at the end of the 
document and are 
formatted with a 
hanging indent 
and double space.

6.2.1

How do you format 
an endnote?
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 Applying References and Hyperlinks 263

 7. SAVE the document as fi rstladies_endnotes in your USB fl ash drive in the lesson 
folder and close the fi le.

PAUSE. LEAVE the document open to use in the next exercise.

CREATING A TABLE OF CONTENTS

A table of contents is usually found at the beginning of a long document to help readers quickly 
locate topics of interest. A table of contents is an ordered list of the topics in a document, 
along with the page numbers on which they are found. In this exercise, you learn to add a head-
ing style and insert a table of contents.

Creating a Table of Contents from Heading Styles
Word makes inserting a table of contents easy using the built-in gallery of styles on the Table of 
Contents menu. The menu includes an automatic format and a manual format. Word automati-
cally builds your table of contents using the Heading 1, Heading 2, and Heading 3 styles. In 
this exercise you will choose one of the automatic formats to create a table of contents (TOC).

 STEP BY STEP Create a Table of Contents

 1. OPEN the website document from the data fi les for this lesson.

 2. On the fi rst page, fourth line, select Planning the site.

 3. On the Home tab, in the Styles group, click the Heading 1 style.

 4. On the next line, select Research. Click the Heading 2 style.

 5. On the next line, select Research and Scheduling. On the Home tab, in the Styles 
group, click the Heading 3 style.

 6. Scroll through the document to verify that all the other headings have the correct 
styles applied to them. Before you can create a table of contents, heading styles must 
be applied to headings in the document as listed in Table 10-1.

The Bottom Line

WileyPLUS Extra! features an 
online tutorial of this task.

Table 10-1

Headings and Styles Applied
Vision and Purpose Heading 3 Risk Assessment Heading 3

Strategic Objectives Heading 3 Design Heading 2

Critical Success Factors Heading 3 Conceptual Design and Prototypes Heading 3

Technology Heading 3 Technology Architecture Heading 3

Risk and Pain Factors Heading 3 Quality Assurance Heading 3

Strategy Heading 2 Implementation Heading 2

Competitive Landscape Heading 3 Content Development Heading 3

Brainstorm Heading 3 Graphic Assets Heading 3

Plan Heading 2 Templates Heading 3

Look and Feel Heading 3 Functionality Testing Heading 3

Project Identifi cation Heading 3 Updated Project Plan Heading 3

Deliverables Heading 3 Stabilization Heading 2

Building the Site Heading 1 Testing Heading 3

Discovery Heading 2 Bug Fixes Heading 3

Team Structure Heading 3 Deployment Heading 3

Content Heading 3 Maintenance Plan Heading 3

Project Plan Heading 3

          The website 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

c10ApplyingReferencesandHyperlinks.indd Page 263  01/08/11  10:44 AM user-f396c10ApplyingReferencesandHyperlinks.indd Page 263  01/08/11  10:44 AM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE



 264 Lesson 10

 7. Return to page 1 by pressing Ctrl+Home and click on a blank line above the Web Site 
Creation Strategy title.

 8. On the References tab, in the Table of Contents group, click the Table of 
Contents button. A gallery of built-in styles and a menu appears, as shown 
in Figure 10-11.

Figure 10-11

Table of Contents menu

Update Table

Table of 
Contents menu

More Table of 
Contents from 
Office.com

Add Text

 9. Select the Automatic Table 2 style. The table of contents is inserted in the 
document—scroll up to see the table of contents (see Figure 10-12). The table of 
contents is shaded in gray and each heading is linked to the document and follows 
the link.

 10. Press the Ctrl key and click the mouse button to follow the link for Research.

 11. SAVE your document as website_template in your USB fl ash drive in the lesson 
folder.

PAUSE. LEAVE the document open to use in the next exercise.

6.3.1

How do you create a table 
of contents using the default 

formats from the built-in 
styles?
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 Applying References and Hyperlinks 265

Formatting a Table of Contents
You can use styles other than Heading 1, Heading 2, and Heading 3 to create a table of contents. 
The Table of Contents Options dialog box provides options for choosing which styles you want 
to include and at what level you would like them to appear in the table of contents.

The Table of Contents dialog box has other options you can specify, including whether to show 
page numbers or right-align page numbers. You can also specify tab leaders, which are the 
symbols that appear between the table of contents topic and the tab set for the corresponding 
page number. In this lesson, you learn to format a table of contents by changing the alignment 
tab leaders and levels.

STEP BY STEP Format a Table of Contents

USE the document that is open from the previous exercise.

 1. On the References tab, in the Table of Contents group, click the Table of Contents 
button.

 2. Select Insert Table of Contents from the menu. The Table of Contents dialog box 
appears, as shown in Figure 10-13. The Print Preview box lists the styles used to 
create the table of contents. The Table of Contents dialog box offers options for you 
to specify whether to show page numbers and whether to right-align those page 
numbers. Tab leaders are symbols that serve as a visual guide from the headings to 
the page numbers. These can appear as periods, hyphens, lines, or none. The format 
for the Table of Contents can be changed to display different heading levels in the 
Table of Contents.

Figure 10-12

Automatic Table 2 style applied
to document

Update Table button will 
open the Update Table of 
Contents dialog box. 

Table of Contents 
button. The drop-down 
arrow will produce the 
Table of Contents menu.
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 266 Lesson 10

 3. Click the Options button. The Table of Contents Options dialog box appears, as shown 
in Figure 10-14. The Options dialog box provides options for choosing which styles to 
include and at what level you want them to appear in the table of contents.

Figure 10-13

Table of Contents
dialog box

Print Preview area

Show page numbers. Check 
mark indicates the page 
numbers will display.

Web Preview area

Tab leaders

Select from many 
different formats (From 
template is default).

Default for levels is 3. 

Right -align page numbers

Figure 10-14

Table of Contents
Options dialog box

Available styles

Scroll bar

 4. In the Build table of contents from section, scroll through the TOC level list. Notice the 
styles and their levels marked for inclusion in the table of contents.

 5. Add a TOC level 4 by keying 4 in the box by Heading 4; a check mark is automatically 
placed by the heading. Click OK to close the Table of Contents Options dialog box, then 
click OK to close the Table of Contents dialog box.

 6. If prompted to replace the selected table of contents, click Yes.

 7. On the Home tab in the Styles group, notice that Heading 4 is now available. Scroll 
down to page 3 and select the RISK AND PAIN FACTORS heading. On the Styles 
group, select Heading 4—the format for the selected text automatically changes and 
the Heading 4 style is applied.

To remove Heading 4, open the Table of Contents dialog box and delete 4.

 8. Press Ctrl+Home to return to the beginning of the document. Click the References tab 
in the Table of Contents group, click the Table of Contents button, and then select Insert 
Table of Contents from the menu. The Table of Contents dialog box opens. Under the 
General section, click the drop-down arrow on the Formats menu and select Formal.

 9. In the Print Preview section, click the drop-down arrow on the Tab leader drop-down 
menu and select hyphens. By default, the Tab leader uses periods.

 10. In the General section, notice that under the Show levels option, 4 levels is displayed. 
Therefore the preview screen displays four levels.

 11. Click OK to close the Table of Contents dialog box. Word displays a prompt asking you 
if you want to replace the selected table of contents. Click Yes.

 12. The new format for the table of contents displays four levels. The Risk and pain factors 
heading is listed as a level four, so it now displays in the table of contents.

 13. SAVE the document as website_template1 in your USB fl ash drive in the lesson folder.

Take Note

6.3.3

How do you set alignments 
for a table of contents?

6.3.4

How do you set tab leaders 
for a table of contents?
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 14. On the Table of Contents group, click the Table of Contents button, and then select 
Insert Table of Contents from the menu.

 15. Click the check box for Right align page numbers to remove the check and turn off 
the right alignment. Notice that the Print Preview area displays no leaders. Click OK. 
A prompt box will appear asking if you want to replace the selected table of contents. 
Click Yes. The table of contents is updated with no alignment set.

 16. SAVE the document as website_template2 in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Modifying a Table of Contents
Modifying a table of contents allows you to change the properties and formatting and to decide 
whether you want to apply the changes to the present document or the Quick Style list, or add 
to the template to reapply. Any changes made will allow you to automatically update the docu-
ment. In this lesson, you learn to modify a table of contents by changing the formatting and 
turning off the Quick Style list.

 STEP BY STEP Modify a Table of Contents

USE the document that is open from the previous exercise.

 1. Position the insertion point in the table of contents. On the References tab in the Table 
of Contents group, click the Table of Contents button, click Insert Table of Contents, 
and then click the Modify button in the lower right of the Table of Contents dialog box. 
The Style dialog box opens with TOC 1 selected, as shown in Figure 10-15.

6.3.2

How do you set levels in a 
table of contents?

Figure 10-15

Style dialog box

Modify

TOC 1 paragraph formats

 2. Click the Modify button from the Style dialog box. The Modify Style dialog box opens, 
as shown in Figure 10-16.

 3. The alignment for TOC 1 is set to align text left; change this to center. Change the 
Font from Calibri to Arial and Size from 10 to 16. The commands shown in the Modify 
Style dialog box resemble the commands on the Home tab, in the Font and Paragraph 
groups.

 4. At the bottom of the dialog box, click the Add to Quick Style list check box to 
remove the check and turn off. Modifi cations made to the style will apply only to this 
document and automatically update the table of contents.

 5. Click OK to accept your changes and close the Modify Style dialog box. Click OK to 
close the Style dialog box. Click OK to close the Table of Contents dialog box.

 6. A prompt will appear asking if you want to replace the selected table of contents. Click 
Yes. Notice the changes made to the Heading 1 style.

6.3.5

How do you modify the styles 
for a table of contents?
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 7. SAVE the document as website_template3 in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Adding Selected Text to a Table of Contents
Sometimes in a table of contents you might want to include text that has not been formatted 
with a heading style. The Add Text menu enables you to choose the level at which the new text 
will appear. The levels available in the previous exercise were Do Not Show in Table of Contents, 
Level 1, Level 2, and Level 3. When working with tables of contents in other documents that 
have more levels, additional options may be available on the menu.

STEP BY STEP Add Selected Text to a Table of Contents

USE the document that is open from the previous exercise.

 1. Scroll to page 2 of the document and position the insertion point before the W in Web 
Site Creation Strategy.

 2. On the Insert tab, in the Pages group, click the Page Break button.

 3. Select the Web Site Creation Strategy text.

 4. On the References tab, in the Table of Contents group, click the drop-down arrow by 
the Add Text button to display the menu.

 5. Select Level 1 from the menu, as shown in Figure 10-17. Deselect the text.

Figure 10-16

Modify Style dialog box Font, font size, bold, 
italics, underline, 
and text color

Preview area

Format button will 
display options to 
select.

Alignment settings

Name of style

Type of style can be 
paragraph or character.

Style based on

Style for following 
paragraph

Figure 10-17

Add Text button and menu

 6. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Updating a Table of Contents
After adding new text, a new page, or modifying the table of contents, the next step is to update 
the table of contents. In this exercise, you learn to update the table of contents.
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STEP BY STEP Update a Table of Contents

USE the document that is open from the previous exercise.

 1. Scroll to the beginning of page 1 and click in the Table of Contents to select it. On the 
References tab, in the Table of Contents group, click the Update Table button.

 2. The Update Table of Contents dialog box appears. The default, Update page numbers 
only, is selected, as shown in Figure 10-18; just click OK. Notice that the page numbers 
for the table of contents have been updated.

Figure 10-18

Update Table of Contents
dialog box

 3. Click Update Table, and the Update Table of Contents dialog box appears. Click the 
Update entire table button, and click OK. Notice that Web Site Creation Strategy 3 is 
added to the table of contents.

 4. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Removing a Table of Contents
Remove a table of contents from the document.

USE the document that is open from the previous exercise.

 1. On the References tab, in the Table of Contents group, click Remove Table of Contents.

 2. Delete the page break.

 3. SAVE the document as website_template_fi nal in your USB fl ash drive in the lesson 
folder.

CLOSE Word.

 Another Way
You can also use 

the shortcut key F9 to open the 
Update the Table of Contents 
dialog box.

6.3.6

How do you update a 
table of contents by page 

numbers only?

6.3.6

How do you update the 
entire table of contents?

 Another Way
You can also update 

a table of contents using the 
shortcut key, F9.

SKILL SUMMARY

In This Lesson
You Learned How To: Exam Objective Objective Number

Apply a hyperlink Apply a hyperlink to text or graphic. 6.1.1
 Use a hyperlink as a bookmark. 6.1.2
 Link a hyperlink to an email address. 6.1.3

Create endnotes Demonstrate the difference between 6.2.1
 and footnotes in a  endnotes and footnotes.
 document Confi gure footnote and endnote format. 6.2.3
 Manage footnote and endnote locations. 6.2.2
 Change footnote and endnote numbering. 6.2.5
 Presentation. 6.2.4

Create a table of Use default formats. 6.3.1
 contents in a Set tab leaders. 6.3.4
 document Set alignment. 6.3.3
 Set levels. 6.3.2
 Modify styles. 6.3.5
 Update a table of contents. 6.3.6
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Knowledge Assessment

True/False
Circle T if the statement is true or F if the statement is false.

T  F   1. A table of contents is usually found at the end of document.

T  F   2.  The manual table of contents option allows you to create a table of 
contents on your own.

T  F   3. You can choose a hyphen as tab leaders for a table of contents.

T  F   4.  Only text formatted with a heading style can be included in a table of 
contents.

T  F   5. You can choose to update only the page numbers in a table of contents.

T  F   6. Hyperlinks can be applied to text or graphics.

T  F   7.  When you create an email link, the Outlook application will automatically 
open.

T  F   8. A bookmark is a reference point in a document.

T  F   9. An endnote is a citation and placed at the end of the document.

T  F  10.  Deleting a footnote or endnote will automatically renumber the remaining 
footnotes or endnotes.

Multiple Choice
Select the best response for the following statements.

 1. A table of contents is located at the ______ of the document.

a. Middle

b. End

c. Beginning

d. None of the above

 2. Tab leaders can be changed into what types of symbols for use in a table of contents?

a. Periods

b. Hyphens

c. Lines

d. All of the above

 3. Which menu will allow you to add content to the table of contents?

a. Update Table

b. Add Text

c. Add Bookmark

d. None of the above

 4. When adding a page or text to a table of contents, it is recommended that you

a. Click the Update Table button on the Ribbon

b. Press F9

c. Click the Update Table button above the table of contents

d. All of the above

 5. By default, a footnote is placed

a. At the beginning of the document

b. At the end of the document

c. At the end of the page

d. Below text
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 6. Formatting a footnote in a document, per MLA style, should be

a. single spaced with a hanging indent and triple spaced

b. single spaced with a hanging indent and doubled spaced between each footnote

c. doubled spaced with a hanging indent and single spaced between each footnote

d. No format is needed.

 7. Hyperlinks can be linked

a. From one page to another page

b. As a website

c. As email

d. All of the above

 8. Reference points in a document are created using which command?

a. Bookmark

b. Hyperlink

c. Email

d. All of the above

 9. The Footnote and Endnote dialog box contains an option to change the page number 
format to

a. Uppercase Roman numerals

b. A1, A2, A3, etc.

c. a and b

d. It is not an option.

 10. Endnotes can be converted to which of the following?

a. Table of contents

b. Footnote

c. Hyperlink

d. They cannot be converted.

Project 10-1:  Mom’s Favorite Recipes
You know that your mom will be sending you more recipes for her cookbook. You decide to create a 
table of contents using headings in the cookbook, making it easy to update as recipes are added.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN momsfavorites1 from the data fi les for this lesson. On the Home tab, turn on 
your Show/Hide command.

 2. Use the Go To command to go to page 3. Select the Breads heading and apply the 
Heading 1 style to it.

 3. Select the Banana Nut Bread/Chocolate Chip Muffi ns heading and apply the Heading 2 
style.

 4. Apply the Heading 2 style to the remaining recipe headings.

 5. On page 1, position the insertion point before the M in Main Dishes.

 6. On the References tab, in the Table of Contents group, click the Table of Contents 
button. Select Automatic Table 1 from the menu.

 7. Center Contents and apply the Title style.

 8. Select the table and click the Update Table button. Update the page numbers only.

 9. SAVE the worksheet as moms_recipes_toc in your USB fl ash drive and CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

Competency Assessment

          The momsfavorites1 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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Project 10-2:  Margie Travel
You will be updating the Explore the World fl yer created in an earlier lesson. Since this fl yer will be 
shared by email, you want to insert hyperlinks and Margie’s email address.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN the exploring_world_fl yer document from the lesson folder.

 2. Select the Explore the World text. On the Insert tab in the Links group, select Hyperlink.

 3. In the address box, key http://www.margiestravel.com. Click OK.

 4. Place the insertion point at the end of the paragraph, press Enter. Key Contact: Margie 
and align right.

 5. Select Margie and in the Links group, click Hyperlink, then select E-mail address.

 6. For the E-mail address, key Margie@margiestravel.com. Click OK.

 7. SAVE the document as world_fl yer_update in your USB fl ash drive and close the fi le.

LEAVE Word open for the next project.

          The exploring_
world_fl yer document 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

Project 10-3:  First Ladies
You will be modifying the First Ladies document by formatting the footnotes and changing the num-
ber format.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN the fi rstladies4 document from the lesson folder.

 2. At the end of page 1, select the fi rst footnote and format the footnote with a hanging 
indent, single space and spacing after to 12 pts. between each footnote.

 3. Complete the same process in step 2 for the second and third footnote.

 4. Place the insertion point after the fi rst footnote below the horizontal line. On the 
References tab in the Footnotes group, launch the Footnote and Endnote dialog box 
and change the number format to lowercase Roman numerals.

 5. SAVE the worksheet as fi rstladies4_update in your USB fl ash drive in the lesson folder 
and CLOSE the fi le.

LEAVE Word open for the next project.

Project 10-4:  Computer Use Policy Contents
Add a table of contents to the Computer Use Policy document.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN computeruse2 from the data fi les for this lesson.

 2. Select the title, Computer Use Policy, and apply the Title style.

 3. Select Section One and apply the Heading 1 style.

 4. Select Purpose and apply the Heading 2 style.

 5. In the same manner, continue applying the Heading 1 and Heading 2 styles to the 
headings for the remainder of the document.

 6. On page 1, position the insertion point before the C in Computer Use Policy and insert 
a built-in table of contents using the Automatic Table 1 style.

 7. With the insertion point in front of the C in Computer Use Policy, insert a page break.

 8. SAVE the document as computer_use_toc in your USB fl ash drive and CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

Profi ciency Assessment

          The fi rstladies4 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

          The computeruse2 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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Project 10-5:  USA Proposal
You need to add a table of contents to the USA Proposal document. However, the document was cre-
ated without using heading styles, and you cannot change the format of the document. Use the Add 
Text command to create a table of contents.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN USAproposal from the data fi les for this lesson.

 2. Use the Add Text command to create a table of contents with three levels. Level 1 will 
be the Proposal Description, Level 2 will be the three Options, and Level 3 will be the 
cities listed under each option.

 3. Add a page break at the beginning of the document and select the hidden mark and 
Clear Formatting and create a blank line.

 4. Key Table of Contents. Change the font to Arial, font size to 20 pts, and spacing after to 
12 pts and center.

 5. Create a manual table of contents using the Formal format.

 6. SAVE the document as USA_proposal_toc in your USB fl ash drive in the lesson folder 
and CLOSE the fi le.

PAUSE. LEAVE Word open for the next exercise.

Project 10-6:  Computer Use Policy Contents Update
You will be using Project 10-4 to update a table of contents.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN the computer_use_toc completed in Project 10-4.

 2. Delete all of Section Seven by selecting text beginning at Section Seven to the end of 
the paragraph under Encryption.

 3. Renumber Section Eight to Section Seven, renumber Section Nine to Section Eight, 
and renumber Section Ten to Section Nine.

 4. Return to the table of contents and update the entire table of contents.

 5. SAVE the worksheet as computer_toc_update and CLOSE the fi le.

CLOSE Word.

Mastery Assessment

          The USAproposal 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

 INTERNET READY

The skills you are learning from this book are giving you a 
good foundation for using Word in the workplace. There 
may be times when you want to perform a task that goes 
beyond what you have already learned. The Internet can be 
a great resource for fi nding additional information. Use the 
Internet to search for information about one of the following 
bookmark topics and then write a brief paragraph answer-
ing the topic’s question or explaining how to accomplish the 
task. Document your sources by including the URL in your 
answer.

 • The Bookmark dialog box has a Hidden Bookmarks 
check box. What is the purpose of this check box? Is it 
possible to hide a bookmark? If so, how?

 • It is easy to delete a bookmark using the Bookmark dialog 
box. Suppose you want to protect bookmarks from being 
deleted. Is this possible? If so, how? If not, why not?

 • List the steps you would follow to create a hyperlink in 
an HTML page to a bookmark in a Word document.

 • You want to highlight the bookmarks in your document 
by making them bold so you can see them better. Is this 
possible? If so, how?
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